VirtualBox

source: vbox/trunk/src/VBox/Installer/linux/rpm/VirtualBox.tmpl.spec@ 57809

Last change on this file since 57809 was 57809, checked in by vboxsync, 9 years ago

Reverted bad commit r102754.

  • Property svn:eol-style set to native
  • Property svn:keywords set to Author Date Id Revision
File size: 16.5 KB
Line 
1#
2# Spec file for creating VirtualBox rpm packages
3#
4
5#
6# Copyright (C) 2006-2015 Oracle Corporation
7#
8# This file is part of VirtualBox Open Source Edition (OSE), as
9# available from http://www.virtualbox.org. This file is free software;
10# you can redistribute it and/or modify it under the terms of the GNU
11# General Public License (GPL) as published by the Free Software
12# Foundation, in version 2 as it comes in the "COPYING" file of the
13# VirtualBox OSE distribution. VirtualBox OSE is distributed in the
14# hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
15#
16
17%define %SPEC% 1
18%define %OSE% 1
19%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
20
21Summary: Oracle VM VirtualBox
22Name: %NAME%
23Version: %BUILDVER%_%BUILDREL%
24Release: 1
25URL: http://www.virtualbox.org/
26Source: VirtualBox.tar
27License: GPLv2
28Group: Applications/System
29Vendor: Oracle Corporation
30BuildRoot: %BUILDROOT%
31Requires: %INITSCRIPTS% %LIBASOUND%
32
33%if %{?rpm_suse:1}%{!?rpm_suse:0}
34%debug_package
35%endif
36
37%MACROSPYTHON%
38
39
40%description
41VirtualBox is a powerful PC virtualization solution allowing
42you to run a wide range of PC operating systems on your Linux
43system. This includes Windows, Linux, FreeBSD, DOS, OpenBSD
44and others. VirtualBox comes with a broad feature set and
45excellent performance, making it the premier virtualization
46software solution on the market.
47
48
49%prep
50%setup -q
51DESTDIR=""
52unset DESTDIR
53
54
55%build
56
57
58%install
59# Mandriva: prevent replacing 'echo' by 'gprintf'
60export DONT_GPRINTIFY=1
61rm -rf $RPM_BUILD_ROOT
62install -m 755 -d $RPM_BUILD_ROOT/sbin
63install -m 755 -d $RPM_BUILD_ROOT%{_initrddir}
64install -m 755 -d $RPM_BUILD_ROOT/lib/modules
65install -m 755 -d $RPM_BUILD_ROOT/etc/vbox
66install -m 755 -d $RPM_BUILD_ROOT/usr/bin
67install -m 755 -d $RPM_BUILD_ROOT/usr/src
68install -m 755 -d $RPM_BUILD_ROOT/usr/share/applications
69install -m 755 -d $RPM_BUILD_ROOT/usr/share/pixmaps
70install -m 755 -d $RPM_BUILD_ROOT/usr/share/icons/hicolor
71install -m 755 -d $RPM_BUILD_ROOT%{_defaultdocdir}/virtualbox
72install -m 755 -d $RPM_BUILD_ROOT/usr/lib/virtualbox
73install -m 755 -d $RPM_BUILD_ROOT/usr/lib/virtualbox/ExtensionPacks
74install -m 755 -d $RPM_BUILD_ROOT/usr/share/virtualbox
75install -m 755 -d $RPM_BUILD_ROOT/usr/share/mime/packages
76mv VBoxEFI32.fd $RPM_BUILD_ROOT/usr/lib/virtualbox || true
77mv VBoxEFI64.fd $RPM_BUILD_ROOT/usr/lib/virtualbox || true
78mv *.rc $RPM_BUILD_ROOT/usr/lib/virtualbox
79mv *.r0 $RPM_BUILD_ROOT/usr/lib/virtualbox
80mv *.rel $RPM_BUILD_ROOT/usr/lib/virtualbox || true
81mv VBoxNetDHCP $RPM_BUILD_ROOT/usr/lib/virtualbox
82mv VBoxNetNAT $RPM_BUILD_ROOT/usr/lib/virtualbox
83mv VBoxNetAdpCtl $RPM_BUILD_ROOT/usr/lib/virtualbox
84if [ -f VBoxVolInfo ]; then
85 mv VBoxVolInfo $RPM_BUILD_ROOT/usr/lib/virtualbox
86fi
87mv VBoxXPCOMIPCD $RPM_BUILD_ROOT/usr/lib/virtualbox
88mv components $RPM_BUILD_ROOT/usr/lib/virtualbox/components
89mv *.so $RPM_BUILD_ROOT/usr/lib/virtualbox
90mv *.so.4 $RPM_BUILD_ROOT/usr/lib/virtualbox || true
91ln -s ../VBoxVMM.so $RPM_BUILD_ROOT/usr/lib/virtualbox/components/VBoxVMM.so
92mv VBoxTestOGL $RPM_BUILD_ROOT/usr/lib/virtualbox
93mv vboxshell.py $RPM_BUILD_ROOT/usr/lib/virtualbox
94(export VBOX_INSTALL_PATH=/usr/lib/virtualbox && \
95 cd ./sdk/installer && \
96 %{__python} ./vboxapisetup.py install --prefix %{_prefix} --root $RPM_BUILD_ROOT)
97rm -rf sdk/installer
98mv sdk $RPM_BUILD_ROOT/usr/lib/virtualbox
99mv nls $RPM_BUILD_ROOT/usr/share/virtualbox
100cp -a src $RPM_BUILD_ROOT/usr/share/virtualbox
101mv VBox.sh $RPM_BUILD_ROOT/usr/bin/VBox
102mv VBoxSysInfo.sh $RPM_BUILD_ROOT/usr/share/virtualbox
103mv VBoxCreateUSBNode.sh $RPM_BUILD_ROOT/usr/share/virtualbox
104cp icons/128x128/virtualbox.png $RPM_BUILD_ROOT/usr/share/pixmaps/virtualbox.png
105cd icons
106 for i in *; do
107 if [ -f $i/virtualbox.* ]; then
108 install -d $RPM_BUILD_ROOT/usr/share/icons/hicolor/$i/apps
109 mv $i/virtualbox.* $RPM_BUILD_ROOT/usr/share/icons/hicolor/$i/apps
110 fi
111 install -d $RPM_BUILD_ROOT/usr/share/icons/hicolor/$i/mimetypes
112 mv $i/* $RPM_BUILD_ROOT/usr/share/icons/hicolor/$i/mimetypes || true
113 rmdir $i
114 done
115cd -
116rmdir icons
117mv virtualbox.xml $RPM_BUILD_ROOT/usr/share/mime/packages
118for i in VBoxManage VBoxSVC VirtualBox VBoxHeadless VBoxDTrace VBoxExtPackHelperApp VBoxBalloonCtrl VBoxAutostart vbox-img; do
119 mv $i $RPM_BUILD_ROOT/usr/lib/virtualbox; done
120if %WEBSVC%; then
121 for i in vboxwebsrv webtest; do
122 mv $i $RPM_BUILD_ROOT/usr/lib/virtualbox; done
123fi
124test -f VBoxSDL && mv VBoxSDL $RPM_BUILD_ROOT/usr/lib/virtualbox
125for i in VirtualBox VBoxHeadless VBoxNetDHCP VBoxNetNAT VBoxNetAdpCtl; do
126 chmod 4511 $RPM_BUILD_ROOT/usr/lib/virtualbox/$i; done
127if [ -f $RPM_BUILD_ROOT/usr/lib/virtualbox/VBoxVolInfo ]; then
128 chmod 4511 $RPM_BUILD_ROOT/usr/lib/virtualbox/VBoxVolInfo
129fi
130test -f VBoxSDL && chmod 4511 $RPM_BUILD_ROOT/usr/lib/virtualbox/VBoxSDL
131if [ -d ExtensionPacks/VNC ]; then
132 mv ExtensionPacks/VNC $RPM_BUILD_ROOT/usr/lib/virtualbox/ExtensionPacks
133fi
134mv VBoxTunctl $RPM_BUILD_ROOT/usr/bin
135%if %{?is_ose:0}%{!?is_ose:1}
136for d in /lib/modules/*; do
137 if [ -L $d/build ]; then
138 rm -f /tmp/vboxdrv-Module.symvers
139 ./src/vboxhost/build_in_tmp \
140 --save-module-symvers /tmp/vboxdrv-Module.symvers \
141 --module-source `pwd`/src/vboxhost/vboxdrv \
142 KBUILD_VERBOSE= KERN_DIR=$d/build MODULE_DIR=$RPM_BUILD_ROOT/$d/misc -j4 \
143 %INSTMOD%
144 ./src/vboxhost/build_in_tmp \
145 --use-module-symvers /tmp/vboxdrv-Module.symvers \
146 --module-source `pwd`/src/vboxhost/vboxnetflt \
147 KBUILD_VERBOSE= KERN_DIR=$d/build MODULE_DIR=$RPM_BUILD_ROOT/$d/misc -j4 \
148 %INSTMOD%
149 ./src/vboxhost/build_in_tmp \
150 --use-module-symvers /tmp/vboxdrv-Module.symvers \
151 --module-source `pwd`/src/vboxhost/vboxnetadp \
152 KBUILD_VERBOSE= KERN_DIR=$d/build MODULE_DIR=$RPM_BUILD_ROOT/$d/misc -j4 \
153 %INSTMOD%
154 ./src/vboxhost/build_in_tmp \
155 --use-module-symvers /tmp/vboxdrv-Module.symvers \
156 --module-source `pwd`/src/vboxhost/vboxpci \
157 KBUILD_VERBOSE= KERN_DIR=$d/build MODULE_DIR=$RPM_BUILD_ROOT/$d/misc -j4 \
158 %INSTMOD%
159 fi
160done
161%endif
162%if %{?is_ose:0}%{!?is_ose:1}
163 mv kchmviewer $RPM_BUILD_ROOT/usr/lib/virtualbox
164 for i in rdesktop-vrdp.tar.gz rdesktop-vrdp-keymaps; do
165 mv $i $RPM_BUILD_ROOT/usr/share/virtualbox; done
166 mv rdesktop-vrdp $RPM_BUILD_ROOT/usr/bin
167%endif
168for i in additions/VBoxGuestAdditions.iso; do
169 mv $i $RPM_BUILD_ROOT/usr/share/virtualbox; done
170if [ -d accessible ]; then
171 mv accessible $RPM_BUILD_ROOT/usr/lib/virtualbox
172fi
173install -D -m 755 vboxdrv.init $RPM_BUILD_ROOT%{_initrddir}/vboxdrv
174ln -sf %{_initrddir}/vboxdrv $RPM_BUILD_ROOT/sbin/rcvboxdrv
175install -D -m 755 vboxballoonctrl-service.init $RPM_BUILD_ROOT%{_initrddir}/vboxballoonctrl-service
176install -D -m 755 vboxautostart-service.init $RPM_BUILD_ROOT%{_initrddir}/vboxautostart-service
177install -D -m 755 vboxweb-service.init $RPM_BUILD_ROOT%{_initrddir}/vboxweb-service
178%if %{?rpm_suse:1}%{!?rpm_suse:0}
179ln -sf ../etc/init.d/vboxballoonctrl-service $RPM_BUILD_ROOT/sbin/rcvboxballoonctrl-service
180ln -sf ../etc/init.d/vboxautostart-service $RPM_BUILD_ROOT/sbin/rcvboxautostart-service
181ln -sf ../etc/init.d/vboxweb-service $RPM_BUILD_ROOT/sbin/rcvboxweb-service
182%endif
183ln -s VBox $RPM_BUILD_ROOT/usr/bin/VirtualBox
184ln -s VBox $RPM_BUILD_ROOT/usr/bin/virtualbox
185ln -s VBox $RPM_BUILD_ROOT/usr/bin/VBoxManage
186ln -s VBox $RPM_BUILD_ROOT/usr/bin/vboxmanage
187test -f VBoxSDL && ln -s VBox $RPM_BUILD_ROOT/usr/bin/VBoxSDL
188test -f VBoxSDL && ln -s VBox $RPM_BUILD_ROOT/usr/bin/vboxsdl
189ln -s VBox $RPM_BUILD_ROOT/usr/bin/VBoxVRDP
190ln -s VBox $RPM_BUILD_ROOT/usr/bin/VBoxHeadless
191ln -s VBox $RPM_BUILD_ROOT/usr/bin/vboxheadless
192ln -s VBox $RPM_BUILD_ROOT/usr/bin/VBoxDTrace
193ln -s VBox $RPM_BUILD_ROOT/usr/bin/vboxdtrace
194ln -s VBox $RPM_BUILD_ROOT/usr/bin/VBoxBalloonCtrl
195ln -s VBox $RPM_BUILD_ROOT/usr/bin/vboxballoonctrl
196ln -s VBox $RPM_BUILD_ROOT/usr/bin/VBoxAutostart
197ln -s VBox $RPM_BUILD_ROOT/usr/bin/vboxautostart
198ln -s VBox $RPM_BUILD_ROOT/usr/bin/vboxwebsrv
199ln -s /usr/lib/virtualbox/vbox-img $RPM_BUILD_ROOT/usr/bin/vbox-img
200ln -s /usr/share/virtualbox/src/vboxhost $RPM_BUILD_ROOT/usr/src/vboxhost-%VER%
201mv virtualbox.desktop $RPM_BUILD_ROOT/usr/share/applications/virtualbox.desktop
202mv VBox.png $RPM_BUILD_ROOT/usr/share/pixmaps/VBox.png
203
204
205%pre
206# defaults
207[ -r /etc/default/virtualbox ] && . /etc/default/virtualbox
208
209# check for active VMs of the installed (old) package
210VBOXSVC_PID=`pidof VBoxSVC 2>/dev/null || true`
211if [ -n "$VBOXSVC_PID" ]; then
212 # executed before the new package is installed!
213 if [ -f /etc/init.d/vboxballoonctrl-service ]; then
214 # try graceful termination; terminate the balloon control service first
215 /etc/init.d/vboxballoonctrl-service stop 2>/dev/null || true
216 fi
217 if [ -f /etc/init.d/vboxautostart-service ]; then
218 # try graceful termination; terminate the autostart service first
219 /etc/init.d/vboxautostart-service stop 2>/dev/null || true
220 fi
221 if [ -f /etc/init.d/vboxweb-service ]; then
222 # try graceful termination; terminate the webservice first
223 /etc/init.d/vboxweb-service stop 2>/dev/null || true
224 fi
225 # ask the daemon to terminate immediately
226 kill -USR1 $VBOXSVC_PID
227 sleep 1
228 if pidof VBoxSVC > /dev/null 2>&1; then
229 echo "A copy of VirtualBox is currently running. Please close it and try again."
230 echo "Please note that it can take up to ten seconds for VirtualBox (in particular"
231 echo "the VBoxSVC daemon) to finish running."
232 exit 1
233 fi
234fi
235
236# check for old installation
237if [ -r /etc/vbox/vbox.cfg ]; then
238 . /etc/vbox/vbox.cfg
239 if [ "x$INSTALL_DIR" != "x" -a -d "$INSTALL_DIR" ]; then
240 echo "An old installation of VirtualBox was found. To install this package the"
241 echo "old package has to be removed first. Have a look at /etc/vbox/vbox.cfg to"
242 echo "determine the installation directory of the previous installation. After"
243 echo "uninstalling the old package remove the file /etc/vbox/vbox.cfg."
244 exit 1
245 fi
246fi
247
248# XXX remove old modules from previous versions (disable with INSTALL_NO_VBOXDRV=1 in /etc/default/virtualbox)
249if [ "$INSTALL_NO_VBOXDRV" != "1" ]; then
250 find /lib/modules -name "vboxdrv\.*" 2>/dev/null|xargs rm -f 2> /dev/null || true
251 find /lib/modules -name "vboxnetflt\.*" 2>/dev/null|xargs rm -f 2> /dev/null || true
252 find /lib/modules -name "vboxnetadp\.*" 2>/dev/null|xargs rm -f 2> /dev/null || true
253 find /lib/modules -name "vboxpci\.*" 2>/dev/null|xargs rm -f 2> /dev/null || true
254fi
255
256
257%post
258#include installer-common.sh
259
260LOG="/var/log/vbox-install.log"
261
262# defaults
263[ -r /etc/default/virtualbox ] && . /etc/default/virtualbox
264
265# remove old cruft
266if [ -f /etc/init.d/vboxdrv.sh ]; then
267 echo "Found old version of /etc/init.d/vboxdrv.sh, removing."
268 rm /etc/init.d/vboxdrv.sh
269fi
270if [ -f /etc/vbox/vbox.cfg ]; then
271 echo "Found old version of /etc/vbox/vbox.cfg, removing."
272 rm /etc/vbox/vbox.cfg
273fi
274rm -f /etc/vbox/module_not_compiled
275
276# XXX SELinux: allow text relocation entries
277%if %{?rpm_redhat:1}%{!?rpm_redhat:0}
278set_selinux_permissions /usr/lib/virtualbox /usr/share/virtualbox
279%endif
280
281# create users groups (disable with INSTALL_NO_GROUP=1 in /etc/default/virtualbox)
282if [ "$INSTALL_NO_GROUP" != "1" ]; then
283 echo
284 echo "Creating group 'vboxusers'. VM users must be member of that group!"
285 echo
286 groupadd -r -f vboxusers 2> /dev/null
287fi
288
289# install udev rule (disable with INSTALL_NO_UDEV=1 in /etc/default/virtualbox)
290# and /dev/vboxdrv and /dev/vboxusb/*/* device nodes
291install_device_node_setup root 0600 /usr/share/virtualbox "${usb_group}"
292%if %{?rpm_redhat:1}%{!?rpm_redhat:0}
293/sbin/chkconfig --add vboxdrv
294/sbin/chkconfig --add vboxballoonctrl-service
295/sbin/chkconfig --add vboxautostart-service
296/sbin/chkconfig --add vboxweb-service
297%endif
298%if %{?rpm_suse:1}%{!?rpm_suse:0}
299%{fillup_and_insserv -f -y -Y vboxdrv vboxballoonctrl-service vboxautostart-service vboxweb-service}
300%endif
301%if %{?rpm_mdv:1}%{!?rpm_mdv:0}
302/sbin/ldconfig
303%_post_service vboxdrv
304%_post_service vboxballoonctrl-service
305%_post_service vboxautostart-service
306%_post_service vboxweb-service
307%update_menus
308%endif
309update-mime-database /usr/share/mime &> /dev/null || :
310update-desktop-database -q > /dev/null 2>&1 || :
311touch --no-create /usr/share/icons/hicolor
312gtk-update-icon-cache -q /usr/share/icons/hicolor 2> /dev/null || :
313
314# Disable module compilation with INSTALL_NO_VBOXDRV=1 in /etc/default/virtualbox
315BUILD_MODULES=0
316REGISTER_MODULES=1
317if [ ! -f /lib/modules/`uname -r`/misc/vboxdrv.ko ]; then
318 REGISTER_MODULES=0
319 if [ "$INSTALL_NO_VBOXDRV" != "1" ]; then
320 # compile problem
321 cat << EOF
322No precompiled module for this kernel found -- trying to build one. Messages
323emitted during module compilation will be logged to $LOG.
324
325EOF
326 BUILD_MODULES=1
327 fi
328fi
329# if INSTALL_NO_VBOXDRV is set to 1, remove all shipped modules
330if [ "$INSTALL_NO_VBOXDRV" = "1" ]; then
331 rm -f /lib/modules/*/misc/vboxdrv.ko
332 rm -f /lib/modules/*/misc/vboxnetflt.ko
333 rm -f /lib/modules/*/misc/vboxnetadp.ko
334 rm -f /lib/modules/*/misc/vboxpci.ko
335fi
336if [ $BUILD_MODULES -eq 1 ]; then
337 /etc/init.d/vboxdrv setup || true
338else
339 if lsmod | grep -q "vboxdrv[^_-]"; then
340 /etc/init.d/vboxdrv stop || true
341 fi
342 if [ $REGISTER_MODULES -eq 1 ]; then
343 DKMS=`which dkms 2>/dev/null`
344 if [ -n "$DKMS" ]; then
345 $DKMS remove -m vboxhost -v %VER% --all > /dev/null 2>&1 || true
346 fi
347 fi
348 /etc/init.d/vboxdrv start > /dev/null
349fi
350/etc/init.d/vboxballoonctrl-service start > /dev/null
351/etc/init.d/vboxautostart-service start > /dev/null
352/etc/init.d/vboxweb-service start > /dev/null
353
354
355%preun
356# $1==0: remove the last version of the package
357# $1==1: install the first time
358# $1>=2: upgrade
359%if %{?rpm_suse:1}%{!?rpm_suse:0}
360%stop_on_removal vboxballoonctrl-service
361%stop_on_removal vboxautostart-service
362%stop_on_removal vboxweb-service
363%endif
364%if %{?rpm_mdv:1}%{!?rpm_mdv:0}
365%_preun_service vboxballoonctrl-service
366%_preun_service vboxautostart-service
367%_preun_service vboxweb-service
368%endif
369%if %{?rpm_redhat:1}%{!?rpm_redhat:0}
370if [ "$1" = 0 ]; then
371 /sbin/service vboxballoonctrl-service stop > /dev/null
372 /sbin/chkconfig --del vboxballoonctrl-service
373 /sbin/service vboxautostart-service stop > /dev/null
374 /sbin/chkconfig --del vboxautostart-service
375 /sbin/service vboxweb-service stop > /dev/null
376 /sbin/chkconfig --del vboxweb-service
377fi
378%endif
379
380if [ "$1" = 0 ]; then
381 # check for active VMs
382 VBOXSVC_PID=`pidof VBoxSVC 2>/dev/null || true`
383 if [ -n "$VBOXSVC_PID" ]; then
384 kill -USR1 $VBOXSVC_PID
385 sleep 1
386 if pidof VBoxSVC > /dev/null 2>&1; then
387 echo "A copy of VirtualBox is currently running. Please close it and try again."
388 echo "Please note that it can take up to ten seconds for VirtualBox (in particular"
389 echo "the VBoxSVC daemon) to finish running."
390 exit 1
391 fi
392 fi
393fi
394%if %{?rpm_suse:1}%{!?rpm_suse:0}
395%stop_on_removal vboxdrv
396%endif
397%if %{?rpm_mdv:1}%{!?rpm_mdv:0}
398%_preun_service vboxdrv
399%endif
400if [ "$1" = 0 ]; then
401%if %{?rpm_redhat:1}%{!?rpm_redhat:0}
402 /sbin/service vboxdrv stop > /dev/null
403 /sbin/chkconfig --del vboxdrv
404%endif
405 rm -f /etc/udev/rules.d/60-vboxdrv.rules
406 rm -f /etc/vbox/license_agreed
407 rm -f /etc/vbox/module_not_compiled
408fi
409DKMS=`which dkms 2>/dev/null`
410if [ -n "$DKMS" ]; then
411 $DKMS remove -m vboxhost -v %VER% --all > /dev/null 2>&1 || true
412fi
413
414
415%postun
416%if %{?rpm_redhat:1}%{!?rpm_redhat:0}
417if [ "$1" -ge 1 ]; then
418 /sbin/service vboxdrv restart > /dev/null 2>&1
419 /sbin/service vboxballoonctrl-service restart > /dev/null 2>&1
420 /sbin/service vboxautostart-service restart > /dev/null 2>&1
421 /sbin/service vboxweb-service restart > /dev/null 2>&1
422fi
423%endif
424%if %{?rpm_suse:1}%{!?rpm_suse:0}
425%restart_on_update vboxdrv vboxballoonctrl-service vboxautostart-service vboxweb-service
426%insserv_cleanup
427%endif
428%if %{?rpm_mdv:1}%{!?rpm_mdv:0}
429/sbin/ldconfig
430%{clean_desktop_database}
431%clean_menus
432%endif
433update-mime-database /usr/share/mime &> /dev/null || :
434update-desktop-database -q > /dev/null 2>&1 || :
435touch --no-create /usr/share/icons/hicolor
436gtk-update-icon-cache -q /usr/share/icons/hicolor 2> /dev/null || :
437rm -rf /usr/lib/virtualbox/ExtensionPacks
438
439
440%clean
441rm -rf $RPM_BUILD_ROOT
442
443
444%files
445%defattr(-,root,root)
446%doc %{!?is_ose: LICENSE}
447%doc UserManual*.pdf
448%doc %{!?is_ose: VirtualBox*.chm}
449%{_initrddir}/vboxdrv
450%{_initrddir}/vboxballoonctrl-service
451%{_initrddir}/vboxautostart-service
452%{_initrddir}/vboxweb-service
453%{?rpm_suse: %{py_sitedir}/*}
454%{!?rpm_suse: %{python_sitelib}/*}
455/sbin/rcvboxdrv
456%{?rpm_suse: /sbin/rcvboxballoonctrl-service}
457%{?rpm_suse: /sbin/rcvboxautostart-service}
458%{?rpm_suse: /sbin/rcvboxweb-service}
459/etc/vbox
460/usr/bin/*
461/usr/src/vbox*
462/usr/lib/virtualbox
463/usr/share/applications/*
464/usr/share/icons/hicolor/*/apps/*
465/usr/share/icons/hicolor/*/mimetypes/*
466/usr/share/mime/packages/*
467/usr/share/pixmaps/*
468/usr/share/virtualbox
Note: See TracBrowser for help on using the repository browser.

© 2024 Oracle Support Privacy / Do Not Sell My Info Terms of Use Trademark Policy Automated Access Etiquette