VirtualBox

Changeset 31999 in vbox for trunk/debian/rules


Ignore:
Timestamp:
Aug 26, 2010 2:03:20 PM (15 years ago)
Author:
vboxsync
svn:sync-xref-src-repo-rev:
65242
Message:

deb: sync

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/debian/rules

    r29781 r31999  
    6060endif
    6161
    62 # Hack: Xandros is actually Debian/sarge ... :(
    63 ifneq ($(wildcard /etc/xandros-desktop-version),)
    64  debrel  := _xandros4.1
    65 else
    66 ifneq ($(wildcard /etc/univention),)
    67  debrel  := _ucs1.3
    68 else
    69  debrel  := $(if $(shell which lsb_release),_$(shell lsb_release -si)_$(shell lsb_release -sc),unknown)
    70 endif
    71 endif
     62debrel  := $(if $(shell which lsb_release),_$(shell lsb_release -si)_$(shell lsb_release -sc),unknown)
    7263
    7364# shipping Linux kernel modules with bleeding-edge releases doesn't make sense
    74 instmod := $(if $(filter _Ubuntu_karmic _Debian_sid,$(debrel)),,1)
     65instmod := $(if $(filter _Ubuntu_lucid _Debian_sid,$(debrel)),,1)
    7566
    7667# Locations of custom built Qt libraries (see below)
     
    8071cfg_flags := $(if $(NOQT),--disable-qt,) \
    8172             $(if $(ose),--ose,) $(if $(LINUX),--with-linux=$(LINUX),) \
    82              $(if $(filter _Ubuntu_dapper,$(debrel)),--with-gcc=gcc-3.4 --with-g++=g++-3.4,) \
    83              $(if $(filter _Ubuntu_gutsy,$(debrel)),--with-gcc=gcc-4.2 --with-g++=g++-4.2,) \
    84              $(if $(filter _xandros4.1 _ucs1.3 _Debian_sarge _Ubuntu_dapper,$(debrel)),--build-libxml2,) \
    85              $(if $(filter _xandros4.1 _ucs1.3 _Debian_sarge _Ubuntu_dapper,$(debrel)),--build-libxslt,) \
    8673             $(if $(filter _Debian_etch,$(debrel)),$(if $(ose),,--build-libcurl),) \
    87              $(if $(filter _Debian_sarge _xandros4.1 _ucs1.3,$(debrel)),--with-qt4-dir=$(qtstdc5)) \
    88              $(if $(filter _Debian_etch _Ubuntu_dapper _Ubuntu_edgy _Ubuntu_feisty _Ubuntu_gutsy _Ubuntu_hardy,$(debrel)),--with-qt4-dir=$(qtstdc6)) \
    89              $(if $(filter _xandros4.1 _ucs1.3,$(debrel)),--disable-sdl-ttf,) \
    90              $(if $(filter _Debian_sarge _Ubuntu_dapper _Ubuntu_edgy _xandros4.1 _ucs1.3,$(debrel)),--disable-pulse,) \
     74             $(if $(filter _Debian_etch _Ubuntu_hardy,$(debrel)),--with-qt4-dir=$(qtstdc6)) \
    9175             $(if $(HEADLESS),--build-headless,) \
    9276             $(if $(DEBUG),--build-debug,) \
     
    10589             $(if $(STAGEDISO),VBOX_WITHOUT_ADDITIONS=1,) \
    10690             $(if $(BLEEDING_EDGE),VBOX_BLEEDING_EDGE=$(BLEEDING_EDGE),) \
    107              $(if $(filter _Debian_sarge _xandros4.1 _ucs1.3,$(debrel)),VBOX_LD_as_needed= ,) \
    10891             $(if $(filter _Debian_etch _Ubuntu_hardy,$(debrel)),,VBOX_WITH_SYSFS_BY_DEFAULT=1)
    10992
    110 # Ubuntu dapper: gcc-4.0 does not work with recompiler, use gcc-3.4 instead
    111 # Ubuntu gutsy:  gcc-4.1 does not work for the webservices, use gcc-4.2 instead
    11293configure: debian/configure-stamp
    11394debian/configure-stamp:
     
    126107        . debian/env.sh && kmk -C $(vboxroot) $(bld_flags) \
    127108            VBOX_NO_LINUX_RUN_INSTALLER=1 \
    128             VBOX_PATH_ADDITIONS.linux.x86=$(builddir)/bin/additions \
     109            VBOX_LNX_ADD_ARCHIVE.x86=$(builddir)/bin/additions/VBoxGuestAdditions-x86-r$(svnrev).tar.bz2 \
     110            VBOX_LNX_ADD_ARCHIVE.amd64=$(builddir)/bin/additions/VBoxGuestAdditions-amd64-r$(svnrev).tar.bz2 \
    129111            packing
    130112        touch debian/build-stamp
     
    238220        dh_installdocs \
    239221            $(archdir)/UserManual*.pdf $(archdir)/VirtualBox*.chm \
    240             LICENSE
    241         rm $(addprefix $(archdir)/,UserManual*.pdf VirtualBox*.chm LICENSE)
     222            $(addprefix $(archdir)/, $(if $(HEADLESS),,License-*.html) LICENSE)
     223        rm $(addprefix $(archdir)/,UserManual*.pdf VirtualBox*.chm \
     224            LICENSE $(if $(HEADLESS),,License-*.html))
    242225        for i in rdesktop-vrdp.tar.gz additions/VBoxGuestAdditions.iso; do \
    243226            mv $(archdir)/$$i $(prefix)/usr/share/$(package); done
     
    263246        $(if $(NOMODS),,dh_installmodules)
    264247        sed \
    265             -e 's|%NOLSB%|$(if $(filter _Debian_sarge ucs1.3,$(debrel)),yes,)|g' \
     248            -e 's|%NOLSB%||g' \
    266249            -e 's|%DEBIAN%|yes|g' \
    267250            -e 's|%PACKAGE%|virtualbox|g' \
    268             src/VBox/Installer/linux/vboxdrv.sh.in > debian/vboxdrv.init
    269         dh_installinit --name=vboxdrv
     251            $(vboxroot)/src/VBox/Installer/linux/vboxdrv.sh.in > debian/vboxdrv.init
     252        dh_installinit --name=vboxdrv --noscripts
     253        sed \
     254            -e 's|%NOLSB%||g' \
     255            -e 's|%DEBIAN%|yes|g' \
     256            -e 's|%PACKAGE%|virtualbox|g' \
     257            $(vboxroot)/src/VBox/Installer/linux/vboxweb-service.sh.in > debian/vboxweb-service.init
     258        dh_installinit --name=vboxweb-service --noscripts
    270259        cat debian/preinst.in | sed -e 's|%VER%|$(ver)|g' > debian/preinst
    271260        cat debian/postinst.in | sed -e 's|%VER%|$(ver)|g' > debian/postinst
    272         if [ "$(debrel)" = "_Ubuntu_dapper" -o "$(debrel)" = "_Debian_sarge" ]; then \
    273             cat debian/postrm.dapper > debian/postrm; fi
    274261        dh_installdebconf
    275262        dh_installchangelogs
     
    302289          -Vpulse=$(if $(HEADLESS),,libpulse0) \
    303290          -Vsdlttf=$(if $(HEADLESS),,libsdl-ttf2.0-0) \
    304           -Vdkms=$(if $(filter _Ubuntu_gutsy _Ubuntu_hardy _Ubuntu_intrepid _Ubuntu_jaunty _Ubuntu_karmic,$(debrel)),dkms,)
     291          -Vdkms=$(if $(filter _Ubuntu_hardy _Ubuntu_intrepid _Ubuntu_jaunty _Ubuntu_karmic _Ubuntu_lucid,$(debrel)),dkms,)
    305292        dh_md5sums
    306293        dh_builddeb --destdir $(pkgdir)
Note: See TracChangeset for help on using the changeset viewer.

© 2024 Oracle Support Privacy / Do Not Sell My Info Terms of Use Trademark Policy Automated Access Etiquette