Changeset 63946 in vbox for trunk/debian/rules
- Timestamp:
- Sep 22, 2016 12:05:35 PM (9 years ago)
- svn:sync-xref-src-repo-rev:
- 110832
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
trunk/debian/rules
r63555 r63946 33 33 # STAGEDISO=<path> don't build the VBoxAdditions, use the precompiled .iso 34 34 # PKGDIR=<path> where to store the final package(s) 35 # BLEEDING_EDGE=xyz36 35 37 36 package := virtualbox … … 65 64 debrel := $(if $(shell which lsb_release),_$(shell lsb_release -si)_$(shell lsb_release -sc),unknown) 66 65 67 # shipping Linux kernel modules with bleeding-edge releases doesn't make sense68 instmod := $(if $(filter _Ubuntu_lucid _Ubuntu_maverick _Ubuntu_natty _Ubuntu_oneiric _Debian_sid,$(debrel)),,1)69 70 66 cfg_flags := $(if $(NOQT),--disable-qt,) \ 71 67 $(if $(ose),--ose,) $(if $(LINUX),--with-linux=$(LINUX),) \ … … 90 86 $(if $(NODOCS),VBOX_WITH_DOCS= ,) \ 91 87 $(if $(VERBOSE),--print-directory KBUILD_VERBOSE=2,--no-print-directory) \ 92 $(if $(STAGEDISO),VBOX_WITHOUT_ADDITIONS=1,) \ 93 $(if $(BLEEDING_EDGE),VBOX_BLEEDING_EDGE=$(BLEEDING_EDGE),) 88 $(if $(STAGEDISO),VBOX_WITHOUT_ADDITIONS=1,) 94 89 95 90 configure: debian/configure-stamp … … 128 123 make -C $(builddir)/bin/src/vboxdrv KERN_DIR=$$d/build MODULE_DIR=$$d clean && \ 129 124 make -j4 -C $(builddir)/bin/src/vboxdrv KBUILD_VERBOSE= KERN_DIR=$$d/build MODULE_DIR=$$d all \ 130 $(if $(instmod),&& install -D -m 0644 -g 0 -o 0 \131 $(builddir)/bin/src/vboxdrv/vboxdrv.ko $(moddir)/$$(basename $$d)/vboxdrv.ko); \132 125 make -C $(builddir)/bin/src/vboxnetflt KERN_DIR=$$d/build MODULE_DIR=$$d clean && \ 133 126 (cp $(builddir)/bin/src/vboxdrv/Module.symvers $(builddir)/bin/src/vboxnetflt || true) && \ 134 127 make -j4 -C $(builddir)/bin/src/vboxnetflt KBUILD_VERBOSE= KERN_DIR=$$d/build MODULE_DIR=$$d all \ 135 $(if $(instmod),&& install -D -m 0644 -g 0 -o 0 \136 $(builddir)/bin/src/vboxnetflt/vboxnetflt.ko $(moddir)/$$(basename $$d)/vboxnetflt.ko); \137 128 make -C $(builddir)/bin/src/vboxnetadp KERN_DIR=$$d/build MODULE_DIR=$$d clean && \ 138 129 (cp $(builddir)/bin/src/vboxdrv/Module.symvers $(builddir)/bin/src/vboxnetadp || true) && \ 139 130 make -j4 -C $(builddir)/bin/src/vboxnetadp KBUILD_VERBOSE= KERN_DIR=$$d/build MODULE_DIR=$$d all \ 140 $(if $(instmod),&& install -D -m 0644 -g 0 -o 0 \141 $(builddir)/bin/src/vboxnetadp/vboxnetadp.ko $(moddir)/$$(basename $$d)/vboxnetadp.ko); \142 131 make -C $(builddir)/bin/src/vboxpci KERN_DIR=$$d/build MODULE_DIR=$$d clean && \ 143 132 (cp $(builddir)/bin/src/vboxdrv/Module.symvers $(builddir)/bin/src/vboxpci || true) && \ 144 133 make -j4 -C $(builddir)/bin/src/vboxpci KBUILD_VERBOSE= KERN_DIR=$$d/build MODULE_DIR=$$d all \ 145 $(if $(instmod),&& install -D -m 0644 -g 0 -o 0 \146 $(builddir)/bin/src/vboxpci/vboxpci.ko $(moddir)/$$(basename $$d)/vboxpci.ko); \147 134 fi; \ 148 135 done … … 255 242 mv $(current)/debian/$(verpkg)/usr/lib/debug $(current)/debian/$(verpkg)-dbg/usr/lib 256 243 endif 257 $(if $(filter _Ubuntu_hardy _Ubuntu_lucid,$(debrel)),dh_pycentral,dh_python2)244 dh_python2 258 245 dh_compress -X.pdf -X.chm -X LICENSE -X.py 259 246 dh_fixperms … … 265 252 -Valsa=$(if $(HEADLESS),,libasound2) \ 266 253 -Vpulse=$(if $(HEADLESS),,libpulse0) \ 267 -Vsdlttf=$(if $(HEADLESS),,libsdl-ttf2.0-0) \ 268 -Vdkms=$(if $(filter _Debian_lenny,$(debrel)),,dkms) 254 -Vsdlttf=$(if $(HEADLESS),,libsdl-ttf2.0-0) 269 255 dh_md5sums 270 256 dh_builddeb --destdir $(pkgdir) -- -Zxz
Note:
See TracChangeset
for help on using the changeset viewer.