Changeset 63946 in vbox for trunk/src/VBox/Installer/linux/debian/rules
- Timestamp:
- Sep 22, 2016 12:05:35 PM (8 years ago)
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
trunk/src/VBox/Installer/linux/debian/rules
r63571 r63946 39 39 # STAGEDISO=<path> don't build the VBoxAdditions, use the precompiled .iso 40 40 # PKGDIR=<path> where to store the final package(s) 41 # BLEEDING_EDGE=xyz42 41 # 43 42 # NODOCS will also be set if UserManual*.pdf and VirtualBox*.chm are placed in … … 75 74 svn info|sed -e "s/^Revision: \(.*\)/-\1/;t;d"; else \ 76 75 date +"-%Y%m%d"; fi))) 77 debver :=$(subst _ALPHA,~alpha,$(subst _BETA,~beta,$(subst _RC,~rc,$(subst _OSE,~ose,$(ver)))))$(svnver)$(if \ 78 $(BLEEDING_EDGE),-$(BLEEDING_EDGE),)$(VERSUFFIX)$(if \ 79 $(HEADLESS),~headless,)$(if $(DEBUG),~dbg,) 76 debver :=$(subst _ALPHA,~alpha,$(subst _BETA,~beta,$(subst _RC,~rc,$(subst _OSE,~ose,$(ver)))))$(svnver)$(VERSUFFIX)$(if $(HEADLESS),~headless,)$(if $(DEBUG),~dbg,) 80 77 archdir := $(prefix)/opt/VirtualBox-$(ver) 81 78 endif … … 120 117 $(if $(NODOCS),VBOX_WITH_DOCS= ,) \ 121 118 $(if $(VERBOSE),--print-directory KBUILD_VERBOSE=2,--no-print-directory) \ 122 $(if $(STAGEDISO),VBOX_WITHOUT_ADDITIONS=1,) \ 123 $(if $(BLEEDING_EDGE),VBOX_BLEEDING_EDGE=$(BLEEDING_EDGE),) 119 $(if $(STAGEDISO),VBOX_WITHOUT_ADDITIONS=1,) 124 120 125 121 configure: debian/configure-stamp … … 158 154 make -C $(builddir)/bin/src/vboxdrv KERN_DIR=$$d/build MODULE_DIR=$$d clean && \ 159 155 make -j4 -C $(builddir)/bin/src/vboxdrv KBUILD_VERBOSE= KERN_DIR=$$d/build MODULE_DIR=$$d all \ 160 $(if $(instmod),&& install -D -m 0644 -g 0 -o 0 \161 $(builddir)/bin/src/vboxdrv/vboxdrv.ko $(moddir)/$$(basename $$d)/vboxdrv.ko); \162 156 make -C $(builddir)/bin/src/vboxnetflt KERN_DIR=$$d/build MODULE_DIR=$$d clean && \ 163 157 (cp $(builddir)/bin/src/vboxdrv/Module.symvers $(builddir)/bin/src/vboxnetflt || true) && \ 164 158 make -j4 -C $(builddir)/bin/src/vboxnetflt KBUILD_VERBOSE= KERN_DIR=$$d/build MODULE_DIR=$$d all \ 165 $(if $(instmod),&& install -D -m 0644 -g 0 -o 0 \166 $(builddir)/bin/src/vboxnetflt/vboxnetflt.ko $(moddir)/$$(basename $$d)/vboxnetflt.ko); \167 159 make -C $(builddir)/bin/src/vboxnetadp KERN_DIR=$$d/build MODULE_DIR=$$d clean && \ 168 160 (cp $(builddir)/bin/src/vboxdrv/Module.symvers $(builddir)/bin/src/vboxnetadp || true) && \ 169 161 make -j4 -C $(builddir)/bin/src/vboxnetadp KBUILD_VERBOSE= KERN_DIR=$$d/build MODULE_DIR=$$d all \ 170 $(if $(instmod),&& install -D -m 0644 -g 0 -o 0 \171 $(builddir)/bin/src/vboxnetadp/vboxnetadp.ko $(moddir)/$$(basename $$d)/vboxnetadp.ko); \172 162 make -C $(builddir)/bin/src/vboxpci KERN_DIR=$$d/build MODULE_DIR=$$d clean && \ 173 163 (cp $(builddir)/bin/src/vboxdrv/Module.symvers $(builddir)/bin/src/vboxpci || true) && \ 174 164 make -j4 -C $(builddir)/bin/src/vboxpci KBUILD_VERBOSE= KERN_DIR=$$d/build MODULE_DIR=$$d all \ 175 $(if $(instmod),&& install -D -m 0644 -g 0 -o 0 \176 $(builddir)/bin/src/vboxpci/vboxpci.ko $(moddir)/$$(basename $$d)/vboxpci.ko); \177 165 fi; \ 178 166 done … … 333 321 mv $(prefix)/usr/lib/debug $(current)/debian/$(verpkg)-dbg/usr/lib 334 322 endif 335 $(if $(filter _Ubuntu_hardy _Ubuntu_lucid,$(debrel)),dh_pycentral,dh_python2)323 dh_python2 336 324 dh_compress -X.pdf -X.chm -X LICENSE -X.py 337 325 dh_fixperms … … 346 334 -Vsdlttf=$(if $(HEADLESS),,libsdl-ttf2.0-0) 347 335 dh_md5sums 348 dh_builddeb --destdir $(pkgdir) -- \ 349 $(if $(filter _Ubuntu_lucid,$(debrel)),,-Zxz) 336 dh_builddeb --destdir $(pkgdir) -- -Zxz 350 337 endif 351 338
Note:
See TracChangeset
for help on using the changeset viewer.