Changeset 84968 in vbox for trunk/debian/rules
- Timestamp:
- Jun 26, 2020 11:51:54 AM (5 years ago)
- svn:sync-xref-src-repo-rev:
- 138846
- File:
-
- 1 edited
Legend:
- Unmodified
- Added
- Removed
-
trunk/debian/rules
r82721 r84968 6 6 7 7 # 8 # Copyright (C) 2006-20 19Oracle Corporation8 # Copyright (C) 2006-2020 Oracle Corporation 9 9 # 10 10 # This file is part of VirtualBox Open Source Edition (OSE), as … … 29 29 # either the subversion rev [if available] or the build date) 30 30 # NODOCS=1 don't build docs, use precompiled UserManual.pdf and 31 # VirtualBox.chm from $HOME31 # maybe VirtualBox.chm from $(vboxroot)/prebuild 32 32 # NOMODS=1 don't build any module 33 33 # NOQT=1 don't build the Qt GUI 34 # NOSDL=1 don't build VBoxSDL 34 35 # EFI=1 include the EFI binary from prebuild 35 36 # HEADLESS=1 build the headless version … … 37 38 # NOWEBSVC=1 don't build the webservice API, default for OSE 38 39 # STAGEDISO=<path> don't build the VBoxAdditions, use the precompiled .iso 40 # STAGEDCHM=<path> use VirtualBox*.chm from this directory 39 41 # PKGDIR=<path> where to store the final package(s) 42 # 43 # NODOCS will be set if UserManual*.pdf is placed in $(vboxroot)/prebuild. 44 # STAGEDISO will be set if VBoxGuestAdditions.iso is placed there. 45 # STAGEDCHM will be set if VirtualBox*.chm is placed there. 46 # VirtualBox*.chm is used if it is provided, but never attempted to be built. 47 # 48 # Wine will not be required if either NODOCS or STAGEDISO are set. 40 49 41 50 package := virtualbox … … 50 59 verfile := $(builddir)/version-generated.mk 51 60 ose := $(if $(OSE),1,$(if $(wildcard $(vboxroot)/src/VBox/RDP/server),,1)) 61 52 62 NOMODS ?= $(ose) 53 63 NOQT ?= $(HEADLESS) 64 NOSDL ?= $(HEADLESS) 54 65 NOWEBSVC ?= $(ose) 55 NOWINE := $(if $(NODOCS),$(if $(STAGEDISO),1,),)$(ose) 66 NODOCS ?= $(if $(wildcard $(vboxroot)/prebuild/UserManual*.pdf),1,) 67 STAGEDISO ?= $(if $(wildcard $(vboxroot)/prebuild/VBoxGuestAdditions.iso),$(vboxroot)/prebuild,) 68 STAGEDCHM ?= $(if $(wildcard $(vboxroot)/prebuild/VirtualBox*.chm),$(vboxroot)/prebuild,) 69 NOWINE := $(if $(NODOCS),1,$(if $(STAGEDISO),1,$(ose))) 56 70 PYTHON := $(firstword $(shell which python) $(shell which python3)) 57 71 … … 71 85 72 86 cfg_flags := $(if $(NOQT),--disable-qt,) \ 87 $(if $(NOSDL),--disable-vboxsdl,) \ 73 88 $(if $(ose),--ose,) $(if $(LINUX),--with-linux=$(LINUX),) \ 74 89 $(if $(HEADLESS),--build-headless,) \ … … 87 102 VBOX_DO_STRIP= \ 88 103 VBOX_PATH_PACKAGE_DOCS="\"/usr/share/doc/$(verpkg)\"" \ 89 $(if $( ose),,VBOX_WITH_DOCS_CHM=1) \104 $(if $(STAGEDCHM),VBOX_WITH_DOCS_CHM=1,VBOX_WITH_KCHMVIEWER=) \ 90 105 $(if $(svnrev),VBOX_SVN_REV=$(svnrev),) \ 91 106 $(if $(NODOCS),VBOX_WITH_DOCS= ,) \ … … 104 119 . debian/env.sh && kmk -C $(vboxroot) $(bld_flags) $(if $(NOPARALLEL),-j1,) all 105 120 $(if $(NODOCS),cp $(vboxroot)/prebuild/UserManual*.pdf $(builddir)/bin,) 106 $(if $( NODOCS),cp $(vboxroot)/prebuild/VirtualBox*.chm $(builddir)/bin,)121 $(if $(STAGEDCHM),cp $(STAGEDCHM)/VirtualBox*.chm $(builddir)/bin,) 107 122 $(if $(EFI),cp $(vboxroot)/prebuild/VBoxEFI32.fd $(builddir)/bin,) 108 123 $(if $(EFI),cp $(vboxroot)/prebuild/VBoxEFI64.fd $(builddir)/bin,) … … 259 274 usr/bin/VBox usr/bin/VBoxManage \ 260 275 usr/bin/VBox usr/bin/vboxmanage \ 261 $(if $( HEADLESS),,usr/bin/VBoxusr/bin/VBoxSDL) \262 $(if $( HEADLESS),,usr/bin/VBoxusr/bin/vboxsdl) \276 $(if $(NOSDL),,usr/bin/VBox usr/bin/VBoxSDL) \ 277 $(if $(NOSDL),,usr/bin/VBox usr/bin/vboxsdl) \ 263 278 $(if $(ose),,usr/bin/VBox usr/bin/VBoxVRDP) \ 264 279 usr/bin/VBox usr/bin/VBoxHeadless \
Note:
See TracChangeset
for help on using the changeset viewer.